Loading...

EtherChannel - Gộp link kết nối giữa 2 switch Cisco

EtherChannel là một kỹ thuật nhóm hai hay nhiều đường kết nối truyền tải dữ liệu vật lý (Link Aggregation) thành một đường ảo duy nhất (Logic) có Port ảo thậm chí cả MAC ảo nhằm mục đích tăng tốc độ truyền dữ liệu và tăng khả năng dự phòng (Redundancy) cho hệ thống.



Ta có hai Switch đang kết nối với nhau bằng cổng Fast Ethernet 100 Mbit trong khi các PC Host kết nối Switch thì dùng cổng Fast với băng thông 1000 Mbit. Hiển nhiên khi mà PC muốn truyền tải một lượng lớn dữ liệu hơn 100 Mbit đi thì tại Switch sẽ xảy ra hiện tượng nghẽn Traffic, các gói tin trong hàng đợi khi quá ngưỡng Cache thi sẽ bị Drop bỏ.

Khi mà dữ liệu truyền tải quá lớn đến nỗi đường truyền không đáp ứng được thì thay vì ta phải nâng cấp hay mua thiết bị mới thì ta sẽ nghĩ tới việc mở thêm nhiều kết nối dây giữa các Switch để cân bằng tải dữ liệu.



Ta có thể kết nối thêm 3 đường dây nữa giúp tăng băng thông cân bằng tải lên 400 Mbit. Tuy nhiên cách chữa cháy này sẽ bị STP chặn lại hoàn toàn nhằm chống hiện tương Loop.



Do vậy EtherChannel sẽ là trợ thủ giúp ta giải quyết vấn đề một cách hiệu quả và tiếp kiệm chi phí nhất. Giữa các Switch ta sẽ tiến hành kết nối nhiều dây và dùng EtherChannel cấu hình ghép các đường vật lý ấy thành một đường ảo, khi đó băng thông đường truyền sẽ tăng tỉ lệ với số kết nối mà ta thêm vào, dữ liệu sẽ được cân bằng tải ra các đường ấy và hiệu suất mạng sẽ tăng lên rõ rệt.



Ngoài ra việc có nhiều kết nối cũng đảm bảo khả năng dự phòng khi mà một trong các đường bị Down thì các đường còn lại sẽ thay thế. Vì EtherChannel ghép các Link lại thành một đường luận lý nên các Switch cũng sẽ ngầm hiểu bó dây ấy chỉ là một đường nên vẫn đảm bảo chống Loop và “Qua mặt” được STP.



Điều kiện cấu hình EtherChannel:

    Các Switch phải đều phải hỗ trợ kỹ thuật EtherChannel và phải được cấu hình EtherChannel đồng nhất giữa các Port kết nối với nhau.
    Các Port kết nối EtherChannel giữa 2 Switch phải tương đồng với nhau:
        Cấu hình (Configuration)
        Tốc độ (Speed)
        Băng thông (Bandwidth)
        Duplex (Full Duplex)
        Native VLAN và các VLANs
        Switchport Mode (Trunking, Access)

Các loại giao thức EtherChannel bao gồm:

    PagP (Cisco Proprietary)
    LACP (IEEE Standard)

Các giao thức trên có thể cấu hình EtherChannel tự động giữa các Switch và cũng có thể được cấu hình tĩnh tùy theo ý muốn của người quản trị, thường thì cấu hình tĩnh được dùng khi ta muốn loại bỏ thời gian đàm phán giữa các Interface.

LACP là giao thức cấu hình EtherChannel chuẩn quốc tế IEEE 802.3ad và có thể dùng được cho hầu hết các thiết bị thuộc các hãng khác nhau, LACP hỗ trợ ghép tối đa 16 Link vật lý thành một Link luận lý (8 Port Active – 8 Port Passive)

LACP có 3 chế độ:

    On: Chế độ cấu hình EtherChannel tĩnh, chế độ này thường không được dùng vì các Switch cấu hình EtherChannel có thể hoạt động được và cũng có thể không hoạt động được vì các Switch được cầu hình bằng tay phục thuộc vào con người nên hoàn toàn không có bước thương lượng trao đổi chính sách giừa bên dẫn đến khả năng Loop cao và bị STP Block.
    Active: Chế độ tự động – Tự động thương lượng với đối tác
    Passive: Chế độ bị động – Chờ được thương lượng



PAgP là giao thức cấu hình EtherChannel độc quyền của các thiết bị hãng Cisco và chỉ hỗ trợ ghép tối đa 8 Link vật lý thành một Link luận lý

PAgP cũng có 3 chế độ tương tự LACP:

    On
    Desirable
    Auto

Cấu hình PAgP

Switch(config)# interface type mod/num
Switch(config-if)# channel-protocol pagp
Switch(config-if)# channel-group number mode {on | {{auto | desirable} [non-silent]}}

Ví dụ:

Switch(config)# interface f0/1 - 4
Switch(config-if)# channel-protocol pagp
Switch(config-if)# channel-group 1 mode desirable

Cấu hình LACP

Switch(config)# lacp system-priority priority
Switch(config)# interface type mod/num
Switch(config-if)# channel-protocol lacp
Switch(config-if)# channel-group number mode {on | passive | active}
Switch(config-if)# lacp port-priority priority

Ví dụ:

Switch1(config)# lacp system-priority 100
Switch1(config)# interface range gig 2/1 – 4 , gig 3/1 – 4
Switch1(config-if)# channel-protocol lacp
Switch1(config-if)# channel-group 1 mode active
Switch1(config-if)# lacp port-priority 100
Switch1(config-if)# exit
Switch1(config)# interface range gig 2/5 – 8 , gig 3/5 – 8
Switch1(config-if)# channel-protocol lacp
Switch1(config-if)# channel-group 1 mode active

Switch1 cấu hình lacp system-priority 100, nếu Switch 2 cấu hình mặc định (không cấu hình câu lệnh này -> sys-priority=32768) thì Switch 1 sẽ có quyền lựa chọn port nào Active, port nào Hot-Standby.
Port gig 2/1 – 4 , gig 3/1 – 4 có port-priority là 100 nhỏ hơn port gig 2/5 – 8 , gig 3/5 – 8 nên gig 2/1 – 4 , gig 3/1 – 4 là Active port, port gig 2/5 – 8 , gig 3/5 – 8 là Hot-Standby Port

Cấu hình Load Balancing:

Switch(config)# port-channel load-balance src-dst-port
 

Cấu hình Etherchannel:

Dưới đây là cấu hình tiến hành đưa 2 port f0/1 và f0/2 vào port channel mode LACP sau đó là cấu hình trunk.

Switch(config)#int range f0/1 – 2
Switch(config-if-range)#channel-group 1 mode ?
active Enable LACP unconditionally
auto Enable PAgP only if a PAgP device is detected
desirable Enable PAgP unconditionally
on Enable Etherchannel only
passive Enable LACP only if a LACP device is detected
Switch(config-if-range)#channel-group 1 mode active
Switch(config-if-range)#exit
Switch(config)# interface port-channel 1
Switch(config-if)#switchport mode trunk

Cấu hình trên là ở Switch 2960, các bạn nếu cấu hình ở Switch khác thì cần thêm câu lệnh

# switchport trunk encapsulation dot1q
Để kiểm tra các bạn có thể sử dụng câu lệnh show etherchannel summary

Switch#show etherchannel summary
Flags: D – down P – in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use f – failed to allocate aggregator
u – unsuitable for bundling
w – waiting to be aggregated
d – default port
Number of channel-groups in use: 1
Number of aggregators: 1Group Port-channel Protocol Ports
——+————-+———–+———————————————-
1 Po1(SU) LACP Fa0/1(P) Fa0/2(P)

Khi show etherchannel summary mà thấy chữ P (in port-channel) tức là bạn đã cấu hình thành công, còn D (down) thì có thể bạn cấu hình chưa đúng, hoặc xem lại dây kết nối.

(Tổng hợp)

 

Comments

No posts found

New post


Liên hệThỏa thuận sử dụng | Chính sách bảo mật | Site map