Loading...

Hướng dẫn cấu hình vPC (virtual Port Channel) trên Switch Cisco Nexus

   vPC là viết tắt của virtual Port Channel, là một công nghệ ảo hóa, được ra mắt vào năm 2009, cho phép các liên kết vật lý trên hai thiết bị Cisco Nexus 3000 5000 7000 hoặc 9000 khác nhau có thể được gom lại thành 1 cổng logic (channel) để kết nối tới các thiết bị Endpoint. Endpoint có thể là một switch, máy chủ, router hoặc bất kỳ thiết bị nào khác như Tường lửa hoặc Bộ cân bằng tải hỗ trợ công nghệ link aggregation LACP (EtherChannel).

   Hướng dẫn cấu hình vPC:

 

Bước 1:

- Bật tính năng vPC và cấu hình vPC domain trên cả 2 switch. vPC domain là thông số để xác định các thiết bị switch Cisco Nexus nào đang chung 1 miền vPC. Các  Switch Nexus trong 1 cụm vPC phải chung vPC Domain:

feature vpc
vpc domain 87

Bước 2:

- Cấu hình vPC Peer Keepalive link, ở đây mình dùng port 3 trên 2 switch, vPC Peer Keepalive Link là đường link Layer 3 được sử dụng để xác định các thiết bị trong cụm vPC và các đường vPC Peer Link có hoạt động hay không. Không có dữ liệu hay các gói tin đồng bộ đi qua vPC Peer Keepalive Link, chỉ có các gói tin IP/UDP sử dụng port 3200 để monitor switch và các peer link trong cụm vPC. Thời gian mặc định của các gói tin này là 1giây và timeout là 5 giây.

Switch Primary:

vrf context keepalive
interface Ethernet1/3
  description "keepalive link"
  no switchport
  vrf member keepalive
  ip address 87.87.87.1/30

Switch Secondary:

vrf context keepalive
interface Ethernet1/3
  description "keepalive link"
  no switchport
  vrf member keepalive
  ip address 87.87.87.2/30

Bước 3:

- Cấu hình keepalive vPC Peer:

Switch Primary:

vpc domain 87
  peer-keepalive destination 87.87.87.2 source 87.87.87.1 vrf keepalive

Switch Secondary:

vpc domain 87
  peer-keepalive destination 87.87.87.2 source 87.87.87.2 vrf keepalive

Bước 4:

- Cấu hình vPC Peer Link trên cả 2 switch, ở đây mình dùng 2 port 1&2 trên 2 switch, vPC peer-link là thành phần kết nối quan trọng nhất trong thiết lập virtual Port Channel. vPC peer-link được sử dụng để đồng bộ hóa trạng thái giữa 2 thiết bị vPC thông qua các gói điều khiển vPC để tạo ra một mặt phẳng điều khiển duy nhất (1 switch logical). Trong trường hợp thiết bị vPC cũng là switch layer 3, vPC peer-link mang các gói Hot Standby Router Protocol (HSRP).

feature lacp
interface port-channel12
  description "VPC Peer Links"
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface Ethernet1/1
  description "VPC Peer Links"
  switchport mode trunk
  channel-group 12 mode active

interface Ethernet1/2
  description "VPC Peer Links"
  switchport mode trunk
  channel-group 12 mode active

Bước 5:

- Cấu hình vPC trên cả 2 switch, nhóm các port trên 2 switch vào 1 channel để kết nối tới các thiết bị khác (Trunk xuống switch Access), ở đây mình dùng 2 cổng 48 trên 2 switch:

interface port-channel11
  switchport mode trunk
  speed 1000
  no negotiate auto
  vpc 11

interface Ethernet1/48
  switchport mode trunk
  speed 1000
  no negotiate auto
  channel-group 11 mode active

Trên switch Access: ( dùng port 1 và 2)

interface port-channel11
 switchport mode trunk
!
interface GigabitEthernet1/0/1
 switchport mode trunk
 channel-group 11 mode active
!
interface GigabitEthernet1/0/2
 switchport mode trunk
 channel-group 11 mode active

Như vậy chúng ta đã cấu hình xong vPC giữa 2 switch Nexus và tạo group port trunk xuống switch Access. Các bạn có thể tham khảo thêm chi tiết tại đây.

Chúc các bạn thành công!

Giá tham khảo Cisco Nexus 


Liên hệThỏa thuận sử dụng | Chính sách bảo mật | Site map